跳到主要內容

ITSA_38_Pro5

[Problem 5] Pseudo Random Generation

成績: 0 / 倒扣: 0.8
Problem Description
Random numbers are usually used in computer program. Computer can't produce pure random numbers but can produce pseudo random numbers. There are some pseudo random generators in our program language library which are usually used.
There is a method which is usually used to produce pseudo random numbers. The method is called linear congruential method. This method needs 4 parameters:


m 
a 
c 
X0
a modulus 
a multiplier 
a addend 
a initial number(seed number)
m > 0
0 < a < m0 ≤ c < m
0 ≤ X0 < m


The pseudo random numbers are produced by follow program states: 
Xn+1 = ( aXn + c ) mod m 
For example, if a = 7, c = 5, m =12, and X0 = 4 then the program produces a series of the pseudo random numbers as follow:


XnaXn + cXn+ 1 = ( aXn + c ) mod m
4 
9
8
1
0
5
33 
68 
61
12 
5 
40
9 
8 
1 
0 
5 
4


In this case, the cycle length of a pseudo random numbers sequence is 6. In other words, the program produces six different pseudo random numbers and the series of the pseudo random numbers will repeat. Theoretically, the cycle length cannot exceed m hat is produced by the method (because mod m).

In this problem, you are given a, c, m, and X0 and asked to computer the cycle length. Note that, the repetition is not necessarily from the first seed. For example, if the pseudo random number sequence is {3, 7, 2, 10, 17, 8, 2, 10, 17, 8, ...} then the cycle length is 4.


Input File Format
In the first line, there is a integer n indicating how many cases. Followed the first line, there are four integers separated by a space in each line. The four integers indicate the numbers of a, c, m and X0 in this order.


Output Format
Output the cycle length of every case line by line.
Example

Sample Input:Sample Output:
2 
2179 1839 3279 1511 
3561 5353 6219 1234
546 
345








-----------------------------------------------------------------------------------------------------------




※使用 hashMap不重複計數的特性






import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;



public class Main {


 public static void main(String[] args) {

  Scanner sc=  new Scanner(System.in);

  int count = 0;

  count  = Integer.parseInt(sc.nextLine().trim());

  while(count-->0)
  {
   int a = sc.nextInt();
 
   int c = sc.nextInt();
 
   int m = sc.nextInt();
 
   int x = sc.nextInt();
 
   int counter = 0,ans = 0;
 
   HashMap<Integer,Integer>  hm = new HashMap<Integer,Integer>();
 
   while(counter<m)
   {
    counter++;
  
    x = (a * x + c) % m ;
  
    if(!hm.containsKey(x))
     hm.put(x, 1);
    else
    {
     int temp = hm.get(x);
     temp++;
     hm.put(x, temp);
    }
   }



//foreach
   for(Map.Entry map:hm.entrySet())
   {
    if(!hm.containsValue(1))
     ans++;
   }
    System.out.println(ans);
  }
  sc.close();
 }
}






留言

這個網誌中的熱門文章

UVA11349

J - Symmetric Matrix Time Limit: 1 sec Memory Limit: 16MB You`re given a square matrix M. Elements of this matrix are M ij : {0 < i < n, 0 < j < n}. In this problem you'll have to find out whether the given matrix is symmetric or not. Definition: Symmetric matrix is such a matrix that all elements of it are non-negative and symmetric with relation to the center of this matrix. Any other matrix is considered to be non-symmetric. For example: All you have to do is to find whether the matrix is symmetric or not. Elements of a matrix given in the input are -2 32  <= M ij  <= 2 32  and 0 < n <= 100. INPUT: First line of input contains number of test cases T <= 300. Then T test cases follow each described in the following way. The first line of each test case contains n - the dimension of square matrix. Then n lines follow each of then containing row i. Row contains exactly n elements separated by a space character. j-th number in row i is the elem

UVA11461

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive). Input The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed. Output For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive). Sample Input 1 4 1 10 0 0 Sample Output 2 3 大意:給兩個數字 求範圍內平方不大於第二個數字的數量 解法: 以最大數取根號後往回看 import java.util.Scanner; public class UVA11461 { public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { int start = sc.nextInt(); int last = sc.nextInt(); if (last == 0) break; System.o

UVA11005

Problem B Cheapest Base Input:  Standard Input Output:  Standard Output When printing text on paper we need ink. But not every character needs the same amount of ink to print: letters such as 'W', 'M' and '8' are more expensive than thinner letters as ' i ', 'c' and '1'. In this problem we will evaluate the cost of printing numbers in several bases. As you know, numbers can be expressed in several different bases. Well known bases are binary (base 2; digits 0 and 1), decimal (base 10; digits 0 to 9) and hexadecimal (base 16; digits 0 to 9 and letters A to F). For the general base  n  we will use the first  n  characters of the string "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", which means the highest base in this problem is 36. The lowest base is of course 2. Every character from this string has an associated cost, represented by an integer value between 1 and 128. The cost to print a number in a certain base is the s