跳到主要內容

UVA10415

Problem E
Eb Alto Saxophone Player
Input: standard input
Output: standard output
Time Limit: 2 seconds
Memory Limit: 16 MB
Do you like saxophone? I have a Eb Alto Saxophone, shown below.

My fingers move A LOT when playing some music, and I'm quite interested in how many times each finger PRESS the button. Assume that the music is composed of only 8 kinds of note. They are: C D E F G A B in one octave and C D E F G A B in a higher octave. We use c,d,e,f,g,a,b,C,D,E,F,G,A,B to represent them. The fingers I use for each note are:
  • c: finger 2~4, 7~10
  • d: finger 2~4, 7~9
  • e: finger 2~4, 7, 8
  • f: finger 2~4, 7
  • g: finger 2~4
  • a: finger 2, 3
  • b: finger 2
  • C: finger 3
  • D: finger 1~4, 7~9
  • E: finger 1~4, 7, 8
  • F: finger 1~4, 7
  • G: finger 1~4
  • A: finger 1~3
  • B: finger 1~2
(Note that every finger is controlling a specified button, different fingers are controlling different buttons.)
Write a program to help count the number of times each finger presses the button. A finger presses a button if it is needed in a note, but not used in the last note. Also, if it is the first note, every finger required presses the button.
Input
The first line of the input is a single integer t(1<=t<=1000), indicating the number of test cases. For each case, there is only one line containing the song. The only allowed characters are {'c','d','e','f','g','a','b','C','D','E','F','G','A','B'}. There are at most 200 notes in a song, and the song maybe empty.
Output
For each test case, print 10 numbers indicating the number of presses for each finger. Numbers are separated by a single space.
Sample Input
3
cdefgab
BAGFEDC
CbCaDCbCbCCbCbabCCbCbabae

Sample Output
0 1 1 1 0 0 1 1 1 1
1 1 1 1 0 0 1 1 1 0
1 8 10 2 0 0 2 2 1 0











解法:先打表存下每一種音符的指法


一旦有新的音符就跟目前的指法比較 只要有按下的動作就++






import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;

public class UVA10415 {

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

Map<Character, String> record = new HashMap<Character, String>();

int volume = Integer.parseInt(sc.nextLine());

record.put(' ', "0000000000");
record.put('c', "0111001111");
record.put('d', "0111001110");
record.put('e', "0111001100");
record.put('f', "0111001000");
record.put('g', "0111000000");
record.put('a', "0110000000");
record.put('b', "0100000000");
record.put('C', "0010000000");
record.put('D', "1111001110");
record.put('E', "1111001100");
record.put('F', "1111001000");
record.put('G', "1111000000");
record.put('A', "1110000000");
record.put('B', "1100000000");

for (int v = 0; v < volume; v++) {

char temp = ' ';

String str = sc.nextLine();

String record_value, former_value;

int count[] = new int[10];

for (int i = 0; i < str.length(); i++) {

record_value = record.get(str.charAt(i));

former_value = record.get(temp);

for (int j = 0; j < 10; j++) {
if (record_value.charAt(j) == '1'
&& former_value.charAt(j) == '0')
count[j]++;
}

temp = str.charAt(i);

}

for (int i = 0; i < 9; i++)
System.out.print(count[i] + " ");

System.out.println(count[9]);

}

sc.close();
}


}






留言

這個網誌中的熱門文章

UVA11349

J - Symmetric Matrix Time Limit: 1 sec Memory Limit: 16MB You`re given a square matrix M. Elements of this matrix are M ij : {0 < i < n, 0 < j < n}. In this problem you'll have to find out whether the given matrix is symmetric or not. Definition: Symmetric matrix is such a matrix that all elements of it are non-negative and symmetric with relation to the center of this matrix. Any other matrix is considered to be non-symmetric. For example: All you have to do is to find whether the matrix is symmetric or not. Elements of a matrix given in the input are -2 32  <= M ij  <= 2 32  and 0 < n <= 100. INPUT: First line of input contains number of test cases T <= 300. Then T test cases follow each described in the following way. The first line of each test case contains n - the dimension of square matrix. Then n lines follow each of then containing row i. Row contains exactly n elements separated by a space character. j-th number in row i is the elem

UVA11461

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive). Input The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed. Output For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive). Sample Input 1 4 1 10 0 0 Sample Output 2 3 大意:給兩個數字 求範圍內平方不大於第二個數字的數量 解法: 以最大數取根號後往回看 import java.util.Scanner; public class UVA11461 { public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { int start = sc.nextInt(); int last = sc.nextInt(); if (last == 0) break; System.o

UVA11005

Problem B Cheapest Base Input:  Standard Input Output:  Standard Output When printing text on paper we need ink. But not every character needs the same amount of ink to print: letters such as 'W', 'M' and '8' are more expensive than thinner letters as ' i ', 'c' and '1'. In this problem we will evaluate the cost of printing numbers in several bases. As you know, numbers can be expressed in several different bases. Well known bases are binary (base 2; digits 0 and 1), decimal (base 10; digits 0 to 9) and hexadecimal (base 16; digits 0 to 9 and letters A to F). For the general base  n  we will use the first  n  characters of the string "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", which means the highest base in this problem is 36. The lowest base is of course 2. Every character from this string has an associated cost, represented by an integer value between 1 and 128. The cost to print a number in a certain base is the s