跳到主要內容

UVA10189

 Problem B: Minesweeper 


The Problem

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):
*...
....
.*..
....
If we would represent the same field placing the hint numbers described above, we would end up with:
*100
2210
1*10
1110
As you may have already noticed, each square may have at most 8 adjacent squares.

The Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

The Output

For each field, you must print the following message in a line alone:
Field #x:
Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input


4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output


Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100






解法: BFS




import java.util.Scanner;

public class UVA10189 {

 public static void main(String[] args) {

  Scanner sc = new Scanner(System.in);

  int field = 0;

  while (sc.hasNext()) {

   String temp[] = sc.nextLine().split(" ");

   int n = Integer.parseInt(temp[0]);
   int m = Integer.parseInt(temp[1]);

   if (n == 0 && m == 0) {
    break;
   }

   field += 1;

   if (field > 1)
    System.out.println();

   String a = null;

   char matrix[][] = new char[n][m];

   int count_mine[][] = new int[n][m];
   

   for (int i = 0; i < n; i++) {

    a = sc.nextLine();

    for (int j = 0; j < m; j++) {

     matrix[i][j] = a.charAt(j);
     
     if (a.charAt(j) == '*')

      count_mine[i][j] = -1;
     else
      count_mine[i][j] = 0;

    }

   }

   for (int i = 0; i < n; i++) {

    for (int j = 0; j < m; j++) {

     if (count_mine[i][j] != -1) {
      int count = 0;

      for (int s = -1; s <= 1; s++) {

       for (int t = -1; t <= 1; t++) {

        if (i + s >= 0 && i + s < n && j + t >= 0
          && j + t < m)

        {

         if (matrix[i + s][j + t] == '*')
          count++;
        }

       }

      }
      count_mine[i][j] = count;
     }

    }

   }

   System.out.println("Field #" + field + ":");

   for (int i = 0; i < n; i++) {

    for (int j = 0; j < m; j++) {

     if (count_mine[i][j] != -1) {
      System.out.print(count_mine[i][j]);
     } else {
      System.out.print('*');
     }

    }
    System.out.println();
   }
  }
 }
}

留言

這個網誌中的熱門文章

UVA11349

J - Symmetric Matrix Time Limit: 1 sec Memory Limit: 16MB You`re given a square matrix M. Elements of this matrix are M ij : {0 < i < n, 0 < j < n}. In this problem you'll have to find out whether the given matrix is symmetric or not. Definition: Symmetric matrix is such a matrix that all elements of it are non-negative and symmetric with relation to the center of this matrix. Any other matrix is considered to be non-symmetric. For example: All you have to do is to find whether the matrix is symmetric or not. Elements of a matrix given in the input are -2 32  <= M ij  <= 2 32  and 0 < n <= 100. INPUT: First line of input contains number of test cases T <= 300. Then T test cases follow each described in the following way. The first line of each test case contains n - the dimension of square matrix. Then n lines follow each of then containing row i. Row contains exactly n elements separated by a space character. j-th number in row i is the elem

UVA11461

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive). Input The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed. Output For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive). Sample Input 1 4 1 10 0 0 Sample Output 2 3 大意:給兩個數字 求範圍內平方不大於第二個數字的數量 解法: 以最大數取根號後往回看 import java.util.Scanner; public class UVA11461 { public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { int start = sc.nextInt(); int last = sc.nextInt(); if (last == 0) break; System.o

UVA11005

Problem B Cheapest Base Input:  Standard Input Output:  Standard Output When printing text on paper we need ink. But not every character needs the same amount of ink to print: letters such as 'W', 'M' and '8' are more expensive than thinner letters as ' i ', 'c' and '1'. In this problem we will evaluate the cost of printing numbers in several bases. As you know, numbers can be expressed in several different bases. Well known bases are binary (base 2; digits 0 and 1), decimal (base 10; digits 0 to 9) and hexadecimal (base 16; digits 0 to 9 and letters A to F). For the general base  n  we will use the first  n  characters of the string "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", which means the highest base in this problem is 36. The lowest base is of course 2. Every character from this string has an associated cost, represented by an integer value between 1 and 128. The cost to print a number in a certain base is the s